martes, 15 de enero de 2008

Actualizar portage en sabayon

Quería actualizar a la ultima versión de portage mi sabayon pero me daba el siguiente error:
[blocks B ] sys-apps/portage-2.1.4_rc1 (is blocking app-shells/bash-3.2_p33)
Buscando en google lo logre hacer, en resumen estos son los pasos:
emerge --sync
layman -S
emerge -1av ~app-shells/bash-3.2_p17
emerge -v portage
etc-update

7 comentarios:

nimiac dijo...

Gracias por el resumen, tenía problemas por no saber si actualizaba correctamente todo.
Un saludo.

Juls dijo...

De nada nimiac que bueno que te haya servido.

ENIO DE LEON dijo...

Llevame sabayon asi lo instalo... :)

Sergio Homar dijo...

Juls hice todos los pasos que pusiste pero al escribir

etc-update

me sale un menu que no mensionaste en el articulo donde dice que si no tengo conocimiento de eso no use el 3,5,7, o algo asi no te puedo decir con exactitud porque no estoy en mi compu pero si puedes ayudarme te agradeceria.
en ese menu le doy opcion 2 y luego me pide otras pero alli se queda le doy en una de las opciones "yes" o "no" y no sale de alli entonces cierro la terminal.

Juls dijo...

yo diría que usaras la opción 3 para que actualice todos los archivos de configuración.

Sergio Homar dijo...

puse la opcion 3 pero como salen 2 menus diferentes no se si estuvo bien, como puedo saber si realmente tengo la mas reciente de portage?
porque al presionar 3 me manda o otro menu pero tambien no lo entiendo mucho que vuelvo a poner opcion 3 de otro menu, pero luego no sale de alli.

Juls dijo...

Si volvés a ejecutar etc-update debería decirte que todo esta actualizado. aquí te dejo un link que talvez de sirva.